$05 Примитивные типы данных и булевы операции

Указание типа данных при работе в модуле необязательно, т.к. типизация «мягкая» и зависит от значения. Кстати тип меняется при присвоении нового значения.

Пример. Переменная типа число

А=3;
// стала строкой
А="строка";

Примитивные типы данных

1. Null

Литерал использующиеся для определения отсутствующего значения при работе с базой данных (при соединении таблиц).

Значение типа Null можно присвоить переменной: Переменная = Null

Также Null нельзя сравнивать с пустой ссылкой, типом Неопределено .

 

2. Неопределено (Undefined)

Значение данного типа применяются, когда необходимо использовать пустое значение, не принадлежащее ни к одному другому типу. Например, такое значение изначально имеют реквизиты с составным типом значения.

 

3. Число (Number)

Данным типом можно представить любое десятичное число.Максимально допустимая разрядность числа 38 знаков. А разделителем является точка «.».

С данными числового типа можно выполнять основные арифметические операции: сложение(+), вычитание(-), умножение(*) или деление(/).

Литералы: Набор цифр вида: [+|-]{0|1|2|3|4|5|6|7|8|9}[.{0|1|2|3|4|5|6|7|8|9}]. Пример: -456465.546

 

4. Строка (String)

Значения данного типа содержат строку в формате Unicode произвольной длины.
Литералы: Набор символов заключенных в кавычки.

Для использования кавычек(«») внутри строки необходимо использовать двойные кавычки.

Пример:

Строка = "ООО ""Организация"""; //Результат: ООО "Организация"

Для переноса строк в модуле, необходимо использовать вертикальную черту ( | )

Пример:

Строка = "ООО ""Организация""
|ООО ""Организация 2""
|ОАО ""Организация 3""";

5. Дата (Date)

Данный тип содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до секунды.
Литералы: Строка цифр, заключенная в одинарные кавычки вида: ‘ГГГГММДДччммсс’:
ГГГГ — год, 4-е цифры;
ММ — месяц:
ДД — дата;
чч — час в 24-х часовом формате;
мм — минуты;
сс — секунды;

В качестве разделителя можно использовать любые символы пример: ‘ГГГГ-ММ-ДД чч:мм:сс’.

 

6. Булево (Boolean)

Значения данного типа имеют два значения Истина и Ложь. Значения возвращаются в результате вычисления логических выражений и часто используются в условиях.
Литералы: Истина (True) и Ложь (False)

Булевы операции

Список булевых операций:

  • И — конъюнкция (булево И), в англоязычном синтаксисе AND;
  • ИЛИ — дизъюнкция (булево ИЛИ), в англоязычном синтаксисе OR;
  • НЕ — логическое отрицание (булево отрицание НЕ), в англоязычном синтаксисе NOT;

Примечание: для управления последовательности необходимо использовать круглые скобки, так же необходимо знать что вычисление происходит слева направо.

Порядок выполнения операций:

  1. Заключенные в скобки;
  2. НЕ;
  3. И;
  4. ИЛИ;
Пример 1. Использование И:

Задача: Если выполняются одновременно 2 условия выводим сообщение

Если ((1=1) И (2=2)) Тогда
      Сообщить ("Условие выполнилось");
КонецЕсли;
// Результат: вывелось сообщение

Если ((1=2) И (2=2)) Тогда
      Сообщить ("Условие выполнилось");
КонецЕсли;
// Результат: сообщение не выполнилось т.к. 1 часть условия не выполняется

 

Пример 2. Использование ИЛИ:

Задача: Если выполняются одно из 2 условий, выводим сообщение

Если ((1=2) ИЛИ (2=2)) Тогда
      Сообщить ("Условие выполнилось");
КонецЕсли;
// Результат: вывелось сообщение

Если ((1=2) ИЛИ (2=3)) Тогда
      Сообщить ("Условие выполнилось");
КонецЕсли;
// Результат: сообщение не выполнилось т.к. оба условия ложны

 

Пример 3. Использование НЕ:

Задача: Если значение не заполнено то вывести сообщение.

Если (НЕ ЗначениеЗаполнено(Значение)) Тогда
      Сообщить ("Условие выполнилось");
КонецЕсли;
// Результат: вывелось сообщение

  

























comments powered by Disqus

Самоучитель по 1С

Популярное