$01 Структура модуля

Структуру модуля, принято делить на 3 раздела:

1.Определение переменных.

Данные переменные будут использоваться в текущем модуле. А если добавить ключевое слово Экспорт, то данные переменные можно использовать вне текущего модуля.

Переменные объявляются с помощью оператора Перем.

В данном разделе можно использовать только операторы Перем.

Рассмотрим несколько примеров:

Перем А, Б, В;

В данном случае мы создали просто 3 переменные, доступные в данном модуле.

Теперь добавим в конец, перед «;» ключивое слово Экспорт.

Перем А, Б, В Экспорт;

Как и говорил, данные переменные будут доступны вне модуля.

2. Раздел процедур и функций.

В данном разделе содержатся операторы Процедура, Функция.

Процедура начинается со слова Процедура, дальше указывается ее название и ее параметры в скобке и заканчивается КонецПроцедуры.

Пример:

Процедура ФормированиеДокумента()
    А=Б;
КонецПроцедуры

Функции модуля начинается со слова Функция, дальше указывается ее название и параметры( в скобке) и заканчивается ключевым словом КонецФункции.

Пример:

Функция ФормированиеДокумента()
    А=Б;
КонецФункции
3. Раздел основной программы

В данном разделе можно описать созданные переменные, выполнить действия с ними.

Пример модуля:

// раздел объявления переменных
Перем А, Б;
Перем В;
// раздел процедур и функций
Процедура Печать ()
  сообщить В;
КонецПроцедуры
// раздел основной программы
А=В;


comments powered by Disqus

Самоучитель по 1С

Популярное