$11 Процедуры

Процедура это секция кода, которую можно вызвать из любого элемента программы или точки исходного кода. Так с помощью процедур можно сократить код программы, за счет использования одной процедуры для нескольких элементов.

Структура процедуры:

в квадратных скобках указываются необязательные элементы.

Процедура <ИмяПроцедуры> ( [ [Знач] <ИмяПараметра> [=<ЗначениеПоУмолчанию>] ], ... ) [Экспорт]
// операторы
[Возврат;]
КонецПроцедуры;

или англоязчный

Procedure <ИмяПроцедуры> ( [ [Знач] <ИмяПараметра> [=<ЗначениеПоУмолчанию>] ], ... ) [Export]
// операторы
[Return;]
EndProcedure;

Описание:

ИмяПроцедуры — наименование процедуры.

Знач — указывает что параметр справа будет использовать значение и передача значения не повлияет на него.

ИмяПараметра — наименование параметра.

ЗначениеПоУмолчанию — значение которое будет браться по умолчанию для параметра.

 … — я так указал что параметров может быть много.

Экспорт — делает доступной данную процедуру из других модулей.

Возврат— завершает работу процедуры.

Пример процедуры
&НаКлиенте
Процедура Команда1(Команда)
    п1=31; п2=2;
    Печать (п1, п2, 3); 
    Сообщить ("Перем1-"+п1); //выдаст 31
    Сообщить ("Перем2-"+п2); //выдаст 22 
КонецПроцедуры
&НаКлиенте
Процедура Печать ( Знач Переменная1, Переменная2, Переменная3=2) Экспорт
   Сообщить ("Перем1-"+Переменная1); // выведет 31 
    Переменная1 = 56; 
    Сообщить ("Перем1(56)-"+Переменная1); // выведет 56 
    Сообщить ("Перем2-"+Переменная2); // выведет 2 
    Переменная2 = 22; 
    Сообщить ("Перем2(22)-"+Переменная2); // выведет 22 
    Сообщить ("Перем3-"+Переменная3); // выведет 3
КонецПроцедуры

 



comments powered by Disqus

Самоучитель по 1С

Популярное