Выбор оборудования для работы с 1С:Предприятием 8

Выбор оборудования для работы с 1С:Предприятием 8

Клиентский компьютер: Операционная система: Microsoft Windows 98/Me, Microsoft Windows 2000/XP/Server 2003/Vista (рекомендуется Microsoft Windows XP) Процессор: Intel Pentium II 400 МГц и выше (рекомендуется Intel Pentium III 866 МГц); Оперативная память: 128 Мбайт и выше (рекомендуется 256 Мбайт); Жесткий диск:...

Преобразовании числа в строку и обратно

Преобразовании числа в строку Число = 2003; Строка = Строка(Число); //Строка = "2 003", длина строки - 5 символов, включая неразрывный пробел //Чтобы преобразовать число к строке без вставки //символа-разделителя групп (неразрывного пробела), //нужно применить функцию Формат с параметром ЧГ=0:...

Создание колонок в таблице значений

1. Создание колонок в новой таблице значений ТабЗначений = Новый ТаблицаЗначений; ТабЗначений .Колонки.Добавить("НомерСтроки", Новый ОписаниеТипов("Число")); ТабЗначений .Колонки.Добавить("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.СотрудникиОрганизаций")); ТабЗначений .Колонки.Добавить("ДатаНачала", Новый ОписаниеТипов("Дата")); 2. Создание колонок в существующей ТабПоле.Колонки.Добавить("ИмяКолонки", Новый ОписаниеТипов("Строка"), "ЗаголовокКолонки"); ЭлементыФормы.ТабПоле.Значение = ТабПоле; ЭлементыФормы.ТабПоле.СоздатьКолонки();

Замена необходимых символов в строке на указанные

Данная функция позволяет найти в исходной строке значение и заменить на другое значение.При разработки конфигураций, часто требуется заменять какие либо символы в строке, по крайне мере я ей часто пользовался для упрощения работы. С данной задачей великолепно справляется функция СтрЗаменить.СинтаксисСтрЗаменить...

Проверка на пустоту тип Дата

Если ПроверяемаяДата = Дата(1, 1, 1) Тогда Сообщить("Дата пустая"); КонецЕсли; Вместо “Дата(1, 1, 1)” можно использовать следующие варианты: '00010101' Дата("00010101") '00010101000000' '0001-01-01' Так же, можно использовать ЗначениеЗаполнено; Если НЕ ЗначениеЗаполнено(Объект.ПеременнаяДата) тогда     сообщить("Строка пустая"); КонецЕсли;   В запросах 1. Дата...

Склонение фамилии, имени и отчества по падежам в 1С 8.1

Версия склонения ФИО для 1C 8.2 Синтаксис Просклонять (<ФИО>, <Падеж>, <Пол>) Параметры <ФИО> – обязательный – строка содержащая фамилию, имя и отчество в именительном падеже единственного числа. Допустимые сочетания фамилии, имени и отчества: ФИО, ИОФ, ИО, ИФ, ФИ, Ф, И, О. Для...

Проверка строки на пустоту

1 способ используя универсальную функцию ЗначениеЗаполнено(<исходная строка>) // если строка пустая или содержит только пробелы // тогда условие выполнится Строка = " "; Если НЕ ЗначениеЗаполнено(Строка) тогда сообщить("Строка пустая"); КонецЕсли; 2 способ сравнив значение с пустым значением (”“) // условие...

Функции для работы с регистром строки

НРег – преобразование символов строки в нижний регистр Синтаксис НРег (<Исходная строка>) Параметры <Исходная строка> – исходная строка. Описание Преобразует все символы строки в нижний регистр. Доступность (для версии 8.2) Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример //...

Проверка на пустоту типа хранилище значений

Функция для проверки “Хранилище значений” на пустоту: Функция ОпределитьЗаполненостьХранилища(Хранилище) Экспорт Если Хранилище.Получить() = Неопределено Тогда Возврат Ложь; Иначе Возврат Истина; КонецЕсли; КонецФункции Второй способ Хранилище.Получить() = Неопределено

Завершение работы пользователей

Нужно создать ярлыки (средствами windows) с командами или запускать через cmd: Для Файлового варианта Отключение пользователей: "C:\Program Files\1cv81\bin\1cv8.exe" ENTERPRISE /F <путь к базе> /N <имя> /P <пароль> /WA- /AU- /DisableStartupMessages /C ЗавершитьРаботуПользователей При этом произойдет запуск программы под админскими правами...

01 Описание объекта конфигурации «Справочник»

Объекты типа «Справочник» служат для работы с некоторым множеством значений. Обычно справочниками являются списки материалов, товаров, организаций, сотрудников и др. Название и структура конкретного справочника определяется при его создании в конфигураторе. Справочники могут быть иерархическими, подчиненными. При настройке может определяться...

2.1. Константы

Набор «значений», которые не меняются довольно длительное время

Самоучитель по 1С

Популярное