$03 Структура операторов

Формат операторов

1- Операторы должны разделятся «;», кроме ключевых слов «КонецФункции» и «КонецПроцедуры». Также можно не ставить на последнем операторе, перед «КонецФункции» или «КонецПроцедуры».

2- Операторы можно разделять на несколько строк, удобно при составлении большой формулы.

Пример 1. В данном примере ошибок нет:

Процедура Печать()
А=2; А=1;
А2=А+
12*0;
А=А2;
Сообщить(А)
КонецПроцедуры

Пример 2. В данном примере есть ошибки, это последняя и предпоследняя строка:

Процедура Печать()
А=2; А=1;
А2=А+12*0
;
А=А2
Сообщить(А);
КонецПроцедуры;
Имена переменных, название процедур и функций.

Имена могут содержать любую последовательность букв, цифр и знака подчеркивания. Имена не могут начинаться с цифр. Также они не могут совпадать с зарезервированными словами системы.

Зарезервированные слова

Список зарезервированных слов, в скобках указывается англоязычный вариант:

Если (If)
Тогда (Then)
ИначеЕсли (Elsif)
Иначе (Else)
КонецЕсли (End If)
Для (For)
Каждого (Each)
Из (In); По (To); Пока (While)
Цикл (Do)
КонецЦикла (End Do)
Процедура (Procedure)
Функция (Function)
КонецПроцедуры (EndProcedure)
КонецФункции (EndFunction)
Перем (Var)
Перейти (Goto)
Возврат (Return)
Продолжить (Continue)
Прервать (Break)
И (And)
Или (Or)
Не (Not)
Попытка (Try)
Исключение (Except)
ВызватьИсключение (Raise)
КонецПопытки (EndTry)
Новый (New)
Выполнить (Execute)
Специальные слова
// обозначается начало комментария
| Вертикальная черта. Используется в строке и обозначает продолжение строки(перенос строки).
~ Знаком тильда начинается метка оператора.
: Двоеточием заканчивается метка оператора.
; Символ разделения операторов.
() С помощью круглых скобок заключается список параметров методов, процедур, функций и конструкторов. Также используются в выражениях встроенного языка (к примеру в условиях).
[] Квадратные скобки. Производят обращение к свойствам объекта по строковому представлению имени свойства. Также возможно обращение к элементам коллекций по индексу или Другому параметру.
, Запятая разделяет параметры в списке параметров методов, процедур, функций и конструкторов.
«» В двойные кавычки заключаются строковые литералы.
» В одинарные кавычки заключаются литералы даты.
. Десятичная точка в числовых литералах.
+ Символ «плюс» обозначает операцию сложения и конкатенации.
Символ «минус» обозначает операцию вычитания.
* Символ «звездочка» обозначает умножение.
/ Символ «косая черта» обозначает деление.
> Правая угловая скобка обозначает логическую опера­цию «больше».
>= Логическая операция «больше или равно».
< Левая угловая скобка обозначает логическую операцию «меньше».
<= Логическая операция «меньше или равно».
= Знак равенства обозначает присвоение или логическую операцию «равно».
<> Две угловые скобки обозначают логическую операцию «не равно».
Прочее

Язык системы 1С:Предприятие позволяет писать код на двух языках: русский и англоязычный. практически все зарезервированные значения, имена типов и т.д. имеют имена на двух языках. Писать код можно смешивать.

Пример:

If (а=а) then
  //d++;
КонецЕсли;

Регистр букв не имеет значения. Т.е. Если вы объявите переменную: «А» и выполните операцию сложения используя «а», ошибок не будет.



comments powered by Disqus

Самоучитель по 1С

Популярное