Встроенный язык 1С

$01 Структура модуля

Структуру модуля, принято делить на 3 раздела: 1.Определение переменных. Данные переменные будут использоваться в текущем модуле. А если добавить ключевое слово Экспорт, то данные переменные можно использовать вне текущего модуля. Переменные объявляются с помощью оператора Перем. В данном разделе можно использовать только операторы Перем....

$02 Обработка для изучения языка

Изучения встроенный язык 1С думаю лучше на примерах, для этого создадим небольшую обработку в пустой конфигурации, которую уже создали. Создание обработки я постараюсь описать подробно, но без описания что я делаю т.к. в данный момент это не важно. 1. Запускаем...

$03 Структура операторов

Формат операторов 1- Операторы должны разделятся «;», кроме ключевых слов «КонецФункции» и «КонецПроцедуры». Также можно не ставить на последнем операторе, перед «КонецФункции» или «КонецПроцедуры». 2- Операторы можно разделять на несколько строк, удобно при составлении большой формулы. Пример 1. В данном примере...

$04 Комментарии

Коментарии это довольно важный элемент любого языка программирования и 1С не исключение, т.к. с помощью них в текте программы можно оставлять любой текст. Обычно спомощю комментариев оставляются пояснения к функциям, модулям и т.д. При исполнении кода программы комментарии игнорируются, следовательно не вредят...

$05 Примитивные типы данных и булевы операции

Указание типа данных при работе в модуле необязательно, т.к. типизация «мягкая» и зависит от значения. Кстати тип меняется при присвоении нового значения. Пример. Переменная типа число А=3; // стала строкой А="строка"; Примитивные типы данных 1. Null Литерал использующиеся для определения отсутствующего значения при...

$06 Операции и приоритет их выполения

Арифметические операции Символ Операция Пример Описание  +  сложение А+Б | А{число} и Б{число}А+Б | А{дата} и Б{число} сложение А и Бприбавляет к Дате Б секунд  —  вычитание А-Б | А{число} и Б{число}А-Б | А{дата} и Б{число}А-Б | А{дата} и Б{дата} Вычитание Б из АВычитание из Даты...

$07 Операторы присваивания

При помощи оператора присваивания присваивается значение переменным, при помощи знака равно «=». Но не стоит путать с равенством. Пример 1. Простое присваивание. Перем Переменная1; Переменная2 = 12; Переменная1 = Переменная2; В рассмотренном случае мы объявили переменную, присвоили 2-ой переменной значение 12 и присвоили переменной...

$08 Условные операторы Если и ИначеЕсли, пример работы с ними

Условный оператор Если позволяет создавать условные выражения, в которых выполняется одно из двух действий в зависимости от значения условия. В 1С есть аналог Case of, для его использования необходимо использовать ИначеЕсли описание ниже.   Структура условия (Русскоязычный синтаксис): Если <Логическое выражение>...

$09 Короткие условия и пример работы с ними

В системе 1с также присутствует сокращенные формы условий. 1-ое это используя ?, котоая похожа на excel и простое условие которое возвращает значение истина или ложь. Структура короткого условия: ?(<Логическое выражение>,<выражение при истине>,<выражение при возврате ложь>,); Пример 1: Число = 1;...

$10 Циклы и примеры работы с ними (Для, Для каждого, Пока)

Цикл Для (For) Оператор цикла Для предназначен для циклического повторения операторов, находящихся внутри цикла. Цикл будет выполнятся пока <переменная> не будет равно или  меньше <КонечноеЗначение>,  <переменная> будет увеличиваться на 1 автоматически. Условие (сравнение) выполняется перед выполнением цикла. Выполнение цикла можно можно прервать в любой момент при помощи...

$11 Процедуры

Процедура это секция кода, которую можно вызвать из любого элемента программы или точки исходного кода. Так с помощью процедур можно сократить код программы, за счет использования одной процедуры для нескольких элементов. Структура процедуры: в квадратных скобках указываются необязательные элементы. Процедура <ИмяПроцедуры> (...

$12 Функции

Функция это секция кода, которую можно выполнить из любой точки исходного кода. В функции заносятся часто используемые действия, к примеру создание строки с инициалами  из фамилии, имени и отчества. Функция начинается с ключевого слова Функция,  заканчивается КонецФункции. Окончание работы функции происходит...

Самоучитель по 1С

Популярное