Склонение фамилии, имени и отчества по падежам в 1С 8.2

Версия для 8.1

Исходный код:

&НаКлиенте
Процедура Команда1(Команда)
  ФИО = "Иванов Иван Иванович";
  Падеж = 2;
  Пол = 1;
  Результат = СклонениеФИО(ФИО, Падеж, пол);
  Сообщить(Результат); 
КонецПроцедуры

&НаСервере
Функция СклонениеФИО(ФИО, Падеж, пол) 
  Результат = "";
  ПутьКФайлу="C:\NAMEDECL.DLL";
  NameDecl = "Склонение";
  Попытка
    Если ПодключитьВнешнююКомпоненту(ПутьКФайлу,NameDecl)ТОгда
      ФункцияСкл = Новый ("AddIn.Склонение.NameDeclension"); 
      Результат = ФункцияСкл.Просклонять(ФИО,Падеж, пол);
    КонецЕсли; 
  Исключение
    Сообщить("Не удалось загрузить внешнюю компаненту по причине: "+ОписаниеОшибки());
  КонецПопытки; 
  Возврат Результат; 
КонецФункции

Описание:

Параметры

<ФИО> – обязательный – строка содержащая фамилию, имя и отчество в именительном падеже единственного числа. Допустимые сочетания фамилии, имени и отчества: ФИО, ИОФ, ИО, ИФ, ФИ, Ф, И, О. Для двойных имен и фамилий использовать “-” (пример: Башлаков-Николаев).
<Падеж> – обязательный – число
Допустимых значений:

1- Именительный
2- Родительный
3- Дательный
4- Винительный
5- Творительный
6- Предложный

<Пол> – необязательный – число.
Возможные значения:

0 – автоопределение (не умеет определять такие имена как КаренАкопян )
1 – мужской
2 – женский.


Скачать внешнею компоненту “NameDecl.dll”



comments powered by Disqus

Популярное