Содержание по функциям 1С

 
Интерактивные (окна и т.д.)
ВвестиДату : вывод окна с вводом даты Вопрос : выводит на экран окно с вопросом. ЗакрытьСправку() : Закроет окно со справкой. ОчиститьСообщения() : Очищает окно сообщений. ПоказатьОповещениеПользователя : выводит глобальное сообщение (оповещение) Предупреждение : выводит сообщение в окно сообщений Сигнал() : Воспроизводит звуковой сигнал. Сообщить() : выводит сообщение в окно сообщений
Константы
Получить : получение значения константы Установить : установка значения константе
Общий (Универсальные)
ЗначениеЗаполнено() : Проверяет на заполненность объект Тип : возвращаем тип по его имени ТипЗнч : Получение текущего типа переменной по ее значению. Формат() : Форматирование значения
Прикладные объекты
ЭтоНовый : Записан ли текущий объект
Работа с датой
ВвестиДату : вывод окна с вводом даты
Результат = ВвестиДату(ДатаРек, "Введите дату рождения", ЧастиДаты.Дата);
  Ввод даты со временем:
Результат = ВвестиДату(ДатаРек, "Введите дату пакупки");
//аналог:
Результат = ВвестиДату(ДатаРек, "Введите дату покупки", ЧастиДаты.ДатаВремя);
Ввод только времени
Результат = ВвестиДату(ДатаРек, "Введите времи прихода на работу", ЧастиДаты.Время);
Обработаем результат:
Если НЕ Результат Тогда
  Сообщить("Дата не введена");
КонецЕсли;
Год : получение года из даты Дата () : преобразование строки в дату Месяц : получение месяца из даты Минута : получение минуты из даты Секунда : получение секунды из даты ТекущаяДата() : текущая дата на компьюторе Час : получение часа из даты  
Работа с типом Булево
Булево() : преобразование числа в значение типа булево.
Работа с числом
ACos, ASin, ATan, Cos, Sin, Tan : Тригонометрические функции Цел () : Получение целой части числа Чило % Число2 : Остаток от деления Число () : преобразование типа Булево или строка в число
Работа со строкой
ВРег () : преобразование символов строки в верхний регистр КодСимвола : Получение кода символа строки, в Unicode. Лев : Выбирает первые слева символы строки. Найти() : поиск в строке НРег () : преобразование символов строки в нижний регистр Прав() : Выбирает последние справа символы строки. ПустаяСтрока() : Проверяет на наличие значащих символов СокрЛ : удаляет незначительные символы слева у строки СокрЛП : удаляет незначительные символы справа и слева в строке СокрП : удаляет незначительные символы справа в строке СтрЗаменить() : Замена символов в строке Строка () : преобразование отличного типа от строки в строку ТРег : титульный регистр слов
Справочники
НайтиПоКоду : Поиск элементов справочника по коду
Если существует несколько элементов, возвращается только 1. Если код отсутствует в справочнике, т.е. установлена длина 0, то возвращается Неопределено.
Пример
КодЭлемента = "000000001";
ТекСправочник = Справочники.Преподаватели;

РезультатПоискаПоКоду = ТекСправочник.НайтиПоКоду(КодЭлемента);
Если РезультатПоискаПоКоду = ТекСправочник.ПустаяСсылка() Тогда
  Сообщить(РезультатПоискаПоКоду.наименование);
Иначе
  Сообщить("Не найден");
КонецЕсли;
НайтиПоНаименованию : Поиск элементов справочника по наименовани Если существует несколько элементов, возвращается только 1.
Пример
НаименованиеЭлемента = "Иванов Иван Иванович";
ТекСправочник = Справочники.Преподаватели;
РезультатПоискаПоНаименованию = ТекСправочник.НайтиПоНаименованию(НаименованиеЭлемента);
Если РезультатПоискаПоНаименованию = ТекСправочник.ПустаяСсылка() Тогда
   Сообщить(РезультатПоискаПоНаименованию.код);
Иначе
   Сообщить("Не найден");
КонецЕсли;


///*******************
///Поиск с учетом родителя:

Университет = Справочники.Университеты.<wbr>НайтиПоНаименованию("МГИМО");
Преподователь = ТекСправочник.<wbr>НайтиПоНаименованию("Иванов Иваон Иванович",,Университет);
НайтиПоРеквизиту : Поиск элементов справочника по произвольному реквизиту Если существует несколько элементов, возвращается только 1. Если реквизит отсутствует в справочнике, то возвращается Неопределено.
Пример
РеквизитСтаж = 12;
ТекСправочник = Справочники.Преподаватели;
РезультатПоискаПоРеквизиту = ТекСправочник.НайтиПоРеквизиту("Стаж",РеквизитСтаж); 
Если РезультатПоискаПоРеквизиту = ТекСправочник.ПустаяСсылка() Тогда
  Сообщить(РезультатПоискаПоРеквизиту.наименование);
Иначе
  Сообщить("Не найден");
КонецЕсли;
ЭтоНовый : Записан ли текущий объект


comments powered by Disqus

Популярное