07. Список активных пользователей и журнала регистрации

В некоторых случаях может потребоваться, просмотреть список активных пользователей и что они делают. К примеру необходимо сделать резервную копию, а в ИБ кто то работает, и необходимо узнать кто и попросить его выйти. Так же пример из личной жизни два сотрудника удалили сотрудников и говорят что это кто то другой это сделал, в результате сознались как да принес распечатанную страницу с информацией кто удалял.

 

1. Просмотр активных пользователей в режиме 1С:Предприятие

Запускаем 1С в режиме «1С:Предприятие».

Открываем Главное меню (рис.1 п.1), находим пункт «сервис» (рис.1 п.2) и нажимаем на «Параметры»(рис.1 п.3)

Рисунок 1. Главное меню

 В открывшемся окне «Параметры», необходимо установить галочку «Отображать команду Все функции» и нажимаем кнопку ОК.

После этого открываем «Главное меню» и выбираем «Все функции…» (рис. 3)

Рисунок 2.

В результате в пункте «Стандартные» будет доступен пункт Активные пользователи, а также Журнал регистрации о котором пойдет речь позже (рис.4).

Рисунок 3.

Пример окна «Активные пользователи». Так же в режиме «1С:Предприятие» у вас могут отсутствовать права на просмотр списка активных пользователей или журнала регистрации.

Рисунок 4. Список активных пользователей

Описание можете прочитать в пункте 2.

 

2. Просмотр активных пользователей в режиме Конфигуратор

1) Запускаем в режиме Конфигуратор.
2) Раскрываем пункт меню «Администрирование» в главном меню.
3) Выбираем пункт «Активные пользователи». (рис. 5)

Рисунок 5.

В результате появится окно со списком активных пользователей. (рис. 6)

Рисунок 6.

В нем можно увидеть такую информацию о активном пользователе как:

  • Имя пользователя (в 1С, не Windows или др.)
  • Имя ПК
  • Приложение (режим запущенного приложения)
  • Начало работы
  • и соединение

Для получения более подробной информации можно воспользоватся «Журналом регистрации».

3. Просмотр действий пользователей

Для данной работы нам потребуется «Журнал регистрации».
Для его запуска необходимо:
1) Запустить 1С в режиме Конфигуратор.
2) Раскрыть в главном меню, пункт «Администрирование».
3) Выбираем пункт «Журнал регистрации». (рис. 5)

В результате вы должны увидеть всю активность данной ИБ.

Вся информация мне редко требовалась, а вот найти определенного пользователя и его действия, время работы кого либо или кто отредактировал определенную информацию требуется часто.

Для этого существует отбор. Для открытия окна отбора данных можно зайти в меню «Действия» и выбрать пункт Отбор или на понели инструментов окна нажать на кнопку «установить отбор» (рис. 7).

Рисунок 7. Установка отбора

С помощью него можно отфильтровать по следующим данным: время, польщователь, имя пк, статосу транзакции, методанными (к примеру по определенному документу), по событию (к примеру только удаление).

Рисунок 8. Форма отбора

4. Просмотр действий активного пользователя

Просмотреть можно с помощью отбора в журнале регистрации, но можно как мне кажется быстрее.
Открываем список активных пользователей, выбираем пользователя и в панели инструментов нажимаем кнопку «работа пользователя».

В результате вы увидите тот же Журнал регистрации с уже готовым отбором по пользователю, который можно отредактировать(к примеру по событию).

 

5. Обработка которая показывает активных пользователей (для 1С версии 8.1)

Не помню зачем ее делал, но только она устроила заказчика. Возможно я к ней прикрутил еще внутренний телефон, информацию о сотруднике или что то в этом духе, но к сожалению конечной версии обработки у меня нет.

Данная процедура вызывалась при срабатывании события ОбновлениеОтображения и при клике кнопки Обновить

Структура таблиц:
Таблица значений 1: АктивныеПользов

Поля:

Пользователь //строка(250)
Приложение  //строка(250)
НачалоРаботы //строка(250)
Компьютер //строка(250)
Соединение //строка(250)

Таблица значений 2:  ВсеПользов

Поля:

Имя  //строка(250)
Пользователь  //строка(250)
Пароль //строка(250)
Роли //строка(250)

Процедура ОбновитьСписокПользователей()
 // активные пользователи
     АктивныеПользов.Очистить();
     СоединенияИнформационнойБазы = ПолучитьСоединенияИнформационнойБазы();
     Для Каждого Соединение Из СоединенияИнформационнойБазы Цикл
         ТЗ=АктивныеПользов.Добавить();
         ТЗ.Пользователь=Соединение.Пользователь.Имя;
         ТЗ.Приложение=ПредставлениеПриложения(Соединение.ИмяПриложения);
         ТЗ.НачалоРаботы=Соединение.НачалоСеанса;
         ТЗ.Компьютер=Соединение.ИмяКомпьютера;
         ТЗ.Соединение=Соединение.НомерСоединения;
     КонецЦикла;
 // все пользователи
     ВсеПользов.Очистить();
     Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей();
     Для Каждого ЭлементМассива Из Выборка Цикл
         ТЗ=ВсеПользов.Добавить();
         ТЗ.Имя = ЭлементМассива.Имя;
         ТЗ.Пользователь = ЭлементМассива.ПолноеИмя;
         ТЗ.Пароль = ЭлементМассива.ПарольУстановлен; //пароль
         Роли = ЭлементМассива.Роли;
         Для Каждого Роль Из Роли Цикл
             ТЗ.Роли = Роль.Имя;
         КонецЦикла;
     КонецЦикла;
 КонецПроцедуры

Если интересно данное решение для 8.2 и не знаете как сделать напишите я сделаю и выложу.



comments powered by Disqus

Самоучитель по 1С

Популярное