$08 Условные операторы Если и ИначеЕсли, пример работы с ними

Условный оператор Если позволяет создавать условные выражения, в которых выполняется одно из двух действий в зависимости от значения условия.

В 1С есть аналог Case of, для его использования необходимо использовать ИначеЕсли описание ниже.

 

Структура условия (Русскоязычный синтаксис):

Если <Логическое выражение> Тогда
    <операторы>
[ИначеЕсли <Логическое выражение 2> Тогда]
    <операторы для иначеЕсли>
[Иначе]
    <операторы>
КонецЕсли;

Ключевое слово Иначе необязательно, т.е. если вам не требуется выполнять каких либо действий при ложном выполнение условия.

Ключевое слово ИначеЕсли также необязательно, необходим в том случае если необходимо выполнить еще одно условие при ложном выполнение условия.

 

Структура условия (Англоязычный синтаксис):

If <Логическое выражение> Then
    <операторы>
[ElsIf <Логическое выражение 2> Then]
    <операторы для иначеЕсли>
[Else]
    <операторы>
EndIf;

 

Пример 1. Простое условие без Иначе

Задача: Если число равно «20» то выводим сообщение «Число = 20».

Число = 20;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
КонецЕсли;
// В первом случае условие выполнилось и вывелось сообщение
Число = 23;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
КонецЕсли;
// Во втором случае условие не выполнилось и не вывелось сообщение

 

Пример 2. С выполнением при ложном результате условия

Задача: Если число равно «20» то выводим сообщение «Число = 20», а если не равно 20 то вывести сообщение «Число <> 20».

Число = 20;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
Иначе
    Сообщить ("Число <> 20");
КонецЕсли;
// В первом случае условие выполнилось и вывелось сообщение "Число = 20"
Число = 23;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
Иначе
    Сообщить ("Число <> 20");
КонецЕсли;
// Во втором случае условие не выполнилось и вывелось сообщение "Число <> 20"

Пример 3. Условие с использованием ИначеЕсли

Если число равно «20» то выводим сообщение «Число = 20», иначе если число равно «23» то вывести сообщение «Число = 23» и если число не равно ни одному числу вывести сообщение «Число неизвестно условному оператору».

Число = 20;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
ИначеЕсли (Число = 23) Тогда
    Сообщить ("Число = 23");
Иначе
    Сообщить ("Число неизвестно условному оператору");
КонецЕсли;
// В первом случае выполнилось первое условие и вывелось сообщение "Число = 20"

Число = 23;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
ИначеЕсли (Число = 23) Тогда
    Сообщить ("Число = 23");
Иначе
    Сообщить ("Число неизвестно условному оператору");
КонецЕсли;
// Во втором случае выполнилось второе условие и вывелось сообщение "Число = 23"

Число = 24;
Если (Число = 20) Тогда
    Сообщить ("Число = 20");
ИначеЕсли (Число = 23) Тогда
    Сообщить ("Число = 23");
Иначе
    Сообщить ("Число неизвестно условному оператору");
КонецЕсли;
// В третьем случае не выполнилось ни одно условие и 
//вывелось сообщение "Число неизвестно условному оператору" 
//т.к. мы обрабатываем ложное выполнение условия


comments powered by Disqus

Самоучитель по 1С

Популярное